1965 Evinrude 9.5 questions

Have a question about your motor? All motor talk and questions go here.
Post Reply
Dowellz
Posts: 32
Joined: 04 Aug 2016, 08:54

1965 Evinrude 9.5 questions

Post by Dowellz » 11 Aug 2016, 19:25

I just picked up a 1978 sylvan boat and it came with this 1965 9.5 hp motor. Model number 9522c.

I can start it super easy but without the choke it won't run. I will post some pictures, I think it's missing some parts?!

Xtremeboats
Dowellz
Posts: 32
Joined: 04 Aug 2016, 08:54

1965 Evinrude 9.5 questions

Post by Dowellz » 11 Aug 2016, 19:31

Ok here you can see a shaft sticking out. No clue what it's suppose to connect to.

Image

Here you can see the shaft goes no where.

Image

Runs with the choke pulled 1/2-3/4 out. Not sure where to start on this thing till I know the motor is complete. Thanks for any info

Dowellz
Posts: 32
Joined: 04 Aug 2016, 08:54

1965 Evinrude 9.5 questions

Post by Dowellz » 11 Aug 2016, 20:56

I imagine that was the slow speed adjustment. Trying to find a diagram to figure out what parts I need to order to make it function like it was suppose to again. This motor looks pretty clean other wise, fires up on the 2-3 pull.

Dowellz
Posts: 32
Joined: 04 Aug 2016, 08:54

1965 Evinrude 9.5 questions

Post by Dowellz » 12 Aug 2016, 09:50

Found a diagram. It's the slow speed adjustment. Those parts aren't cheap! Image

Maybe I can adjust it without those parts, be nice to return it to 100% working order tho.

User avatar
wmk0002
Posts: 596
Joined: 17 Apr 2014, 15:39
Location: Cullman, Alabama

1965 Evinrude 9.5 questions

Post by wmk0002 » 12 Aug 2016, 09:54

I'd buy things like choke knobs and slow speed knobs and cables off of Ebay rather than new OEM.
2016 Alumacraft 1648 NCS - 1992 Johnson 9.9 HP Tiller
http://www.tinboats.net/forum/viewtopic ... 21&t=40764

User avatar
Pappy
Donor
Posts: 2720
Joined: 15 May 2010, 00:38
Location: Central Florida

1965 Evinrude 9.5 questions

Post by Pappy » 13 Aug 2016, 10:03

No, your engine is NOT complete!
The shaft you see that goes nowhere is an offset mixture control. It is missing the knob on the outside and the linkage that connects it to the mixture control on the front of the carburetor. Adjust the mixture on the front of the carb for the time being and see if it helps.

Dowellz
Posts: 32
Joined: 04 Aug 2016, 08:54

1965 Evinrude 9.5 questions

Post by Dowellz » 13 Aug 2016, 10:06

Thanks for the reply. I will look up the base adjustment and try it out. Wouldn't happen to know where to initially set it would you?

User avatar
Pappy
Donor
Posts: 2720
Joined: 15 May 2010, 00:38
Location: Central Florida

1965 Evinrude 9.5 questions

Post by Pappy » 13 Aug 2016, 10:22

1 1/2 turns and go in from there.

CMOS
Posts: 341
Joined: 12 Nov 2014, 11:32
Location: Magnolia, TX

1965 Evinrude 9.5 questions

Post by CMOS » 12 Sep 2016, 10:48

I basically have that same motor - 66 Johnson 9.5 but mine has the flex cable to adjust the slow speed needle.

Darn fine motors. Be glad to answer any questions I can.

CMOS
1963 Lone Star 14' "Commander" with a 1998 25 HP Mercury
1982 Johnson 15 HP - in pieces, in progress :wink:

Post Reply