1975 Johnson 25hp Electric Start

Have a question about your motor? All motor talk and questions go here.
Post Reply
khanderton
Posts: 6
Joined: 04 Feb 2016, 14:22

1975 Johnson 25hp Electric Start

Post by khanderton » 02 Sep 2016, 13:50

Just recently, I have been having difficulties starting my motor w/ electric start when the motor is cold. I can pull the rope and it starts. Once started, I can shut it off, and the electric start will work w/o issue. I only seem to have the issue when the motor is cold.

Any thoughts on this issue?

Thanks in advance.


Sent from my iPad using Tapatalk

Xtremeboats
User avatar
rednecknproud21
Posts: 97
Joined: 08 Jul 2015, 08:37
Location: Greenfield, Indiana

Re: 1975 Johnson 25hp Electric Start

Post by rednecknproud21 » 02 Sep 2016, 13:54

Safety neutral switch is probably intermittently working

Sent from my XT1254 using Tapatalk

User avatar
rednecknproud21
Posts: 97
Joined: 08 Jul 2015, 08:37
Location: Greenfield, Indiana

Re: 1975 Johnson 25hp Electric Start

Post by rednecknproud21 » 02 Sep 2016, 13:54

My 1973 did they same thing when I got it changed the switch and now it works like it should

Sent from my XT1254 using Tapatalk

User avatar
earl60446
Posts: 1199
Joined: 17 Dec 2010, 12:15
Location: Kankakee County, IL

1975 Johnson 25hp Electric Start

Post by earl60446 » 02 Sep 2016, 18:36

Maybe a low battery when cranking the starter. Monitor with voltmeter when trying to start.
Tim
16ft 1989 Fisher SV-2 w 1988 48hp SPL Johnson "CIGAR BARGE"
(engine looks like a wreck but runs great)
Used to have 1972 14ft Lund w 1977 15hp Mariner
(engine looked great but always ran marginal)
XLINE SPORTSMANS CLUB

Post Reply